Tagged: 

This topic contains 7 replies, has 2 voices, and was last updated by ee1 ee1 4 months, 1 week ago.

  • Author
    Posts
  • #74965
    ee1
    ee1
    Participant

    For starters I am trying to set up a server side version of the calendar on FMS 17. I put the sosimple folder into the htdocs folder and gave the fmserver user read and write access to the cache folder. When I hit done, where the calendar should show up it says

    “You don’t have permission to access the requested directory. There is either no index document or the directory is read-protected.You don’t have permission to access the requested object. It is either read-protected or not readable by the server.”

    I think I have everything set up correctly permissions wise, but obviously I messed something up. If you need to know anything more please ask. Fairly new to the admin side of filemaker.

    • This topic was modified 4 months, 1 week ago by ee1 .
  • #74968
    admin
    admin
    Keymaster

    It doesn’t sound like a permissions issue – sounds like the wrong folder in the wrong place.

    1) Make sure you’re copying the right folder. It’s the one named “sosimple” and it was originally inside the folder called “for server-side installations”. It contains the cache folder and the sosimple_cal.php file, among other things.

    2) Make sure you’re putting it in the right place. Our installation document specifies the correct place. Please note that there are two options on the Mac, one for secure one for not – make sure you know which one you’re using.

    Before you look at it in FileMaker Pro, first look at the sosimple page in your browser. The sosimple page (same url without any parameters) shows information about any missing pieces to your installation.

    More installation info:

    https://www.sosimplesoftware.com/products/calendar-documentation/calendar-builder-reference/calendar-modes/how-server-powered-works/installing/

  • #74969
    ee1
    ee1
    Participant

    Thanks for your quick reply!

    1) That is the folder that I am copying, it contains those files.

    2) I am using the secure version and it is in the folder directed by that page. (httpsroot). I have also tried the non secure just to test and i get the exact same message.

    I followed those directions, and have tried restarting the process in case I messed something up, but I cant seem to find the issue.

     

  • #74970
    admin
    admin
    Keymaster

    Also, in FileMaker 17, PHP can only be turned on by the command line. Have you turned it on?

    Ken

  • #74971
    admin
    admin
    Keymaster

    That is exactly the message you’d see if PHP was not enabled on your server.

    Enable PHP by opening the Terminal app on your server and typing the following:

    fmsadmin SET CWPCONFIG ENABLEPHP=true ENCODING=UTF-8 LOCALE=en PREVALIDATION=false USEFMPHP=true

  • #74972
    ee1
    ee1
    Participant

    I am getting “invalid command” when I copied that command over to fmsadmin. When I deleted everything after the first ‘true’ it worked, but I was unable to get it to go through otherwise. It said that php was set to true though when I use the shorter version, which is what was on the filemaker server 17 setup guide.

  • #74973
    admin
    admin
    Keymaster

    You have to restart server after you turn on PHP.

  • #74974
    ee1
    ee1
    Participant

    You’re amazing, got it up,  thanks for helping me out!

You must be logged in to reply to this topic.