This topic contains 6 replies, has 2 voices, and was last updated by admin admin 5 months, 1 week ago.

  • Author
    Posts
  • #75055
    BobMillerMagic
    BobMillerMagic
    Participant

    I used to have a working calendar. Now I can’t get anything to show in my calendar. I’ve gone all the way back to the beginning several times. I’ve gone back to using the original script. I’ve re-pasted the new web view a hundred times. I have no idea why it’s not working. Something just switched off. I know you probably have no idea what happened, but why wouldn’t anything show not in Settings or in my FM app. Any guesses?

  • #75056
    admin
    admin
    Keymaster

    Of course, not a lot of details to go on.

    But the first thing that comes to mind is your PHP server stopped working. Rebooting the server, or re-deploying the FileMaker web engine usually gets that kick-started.

    If you open the soSIMPLE Calendar Settings file, and click on your calendar setting name, you should see the calendar, and see the events on the calendar. No reason to mess with scripts, or re-pasting anything unless you see your calendar in the settings file.

    I usually go one step further, and take the URL for my calendar and paste it into my favorite browser (Chrome, for me). Sometimes the browser will show an error that will make it all obvious, where FileMaker’s web viewer doesn’t show anything.

  • #75057
    BobMillerMagic
    BobMillerMagic
    Participant

    I started over from brand New like I had nothing. Now I see the events, finally. I’ll have to re-hook the scripts and the Resources fields. But at least I see results again.

  • #75058
    admin
    admin
    Keymaster

    Great to hear.

    Did you have to reinstall anything, or just re-create your data source?

  • #75059
    BobMillerMagic
    BobMillerMagic
    Participant

    Just recreate data source

     

  • #75060
    BobMillerMagic
    BobMillerMagic
    Participant

    It happened again. I was working on the calendar today and it just stopped displaying. I don’t think it was b/c of anything I did. So I immediately created a new one, recreating the datasource from the previous, and now all the events show again.

    It’s a client-side script with about 120 events. I thought it might have been the show only flag b/c I’d been experimenting with that so I set all of those fields to empty, but that didn’t matter.

    I went back and checked other calendars I’d created that had stopped showing and they still don’t show either. I can only see the one I just made.

     

  • #75061
    admin
    admin
    Keymaster

    First thing to check – make sure your cache folder is caching data. You can look directly in the folder on your PHP server (“cache” inside the sosimple folder). If it isn’t getting updated, check your installation.

    If it is getting updated, is it possible that you’re making frequent changes in your settings file (settings changes force a cache flush)? If this is what’s happening, you’ll see a bunch of “web” users connecting in the Admin Console. Ejecting them will allow your calendar continue updating data.

    Let me know if that’s what’s happening.

You must be logged in to reply to this topic.