This topic contains 9 replies, has 2 voices, and was last updated by admin admin 5 months ago.

  • Author
    Posts
  • #75029

    Eric

    I am having a problem trying to do a test integration into my own file.  Every time I hit the copy calendar scripts to the clipboard in order to paste them into my solution I get the following error:  “MBS.fms64” failed to initialize.

    I have tried:

    Both stand alone and server powered modes.

    Plug ins are enabled.

    I have uninstalled and reinstalled FilemakerPro(v17).

    If I go to Preferences/Plug-Ins it does not show up in the box of enabled plug ins, but if I click reveal Plug-In folder I do see a MBS.fmx64 file.

    There is a check box in the allow solutions to install files.

    After closing filemaker and re-opening I do see MBS Plug-In in the enabled plug-ins, but there is no check box.  When I click on the check box I get: “?” failed to initialize.

    Any thoughts as to what is going on?

  • #75033
    admin
    admin
    Keymaster

    We will have to check with MBS about this error. I haven’t heard of this one before.

    In the meantime, try these steps:

    1. Open FileMaker and reveal the plugin folder
    2. Delete the copy that’s there.
    3. Quit FileMaker
    4. Open FileMaker and open soSIMPLE Settings
    5. Quit FileMaker
    6. Open FileMaker and open soSIMPLE Settings again – go to preferences – is MBS in there?
    7. Check the box next to MBS if it’s not checked.
    8. If it give you that error again, quit one more time and re-open.

    If that process doesn’t yield any results, reply back with system information – version of OS, version of soSIMPLE, version of MBS, version of FileMaker Pro. If you feel more comfortable, feel free to click the “Set as private reply” button.

    Thanks

    • #75036

      Eric

      Thank you, I will try this as soon as I get a chance and let you know the results.  I am also going to try on a different computer and see if it works.

  • #75039
    admin
    admin
    Keymaster

    There may be a Windows issue loading this plugin. Please let me know if it’s working now, and on which platform.

    Thanks.

    In your reply, let me know the

    • version of Windows,
    • 32/64bit?,
    • version of FMP,
    • version of MBS.
  • #75079

    Carole Chaski

    Hello, I also have this error. I actually have the MBS plugin and use it independent of SoSimple. I do not wan tto delete the plugin as advised. I am willing to manually copy the scripts (this is what my error messages advises). Where do I find the scripts to be copied? Thank you

  • #75080
    admin
    admin
    Keymaster

    Hi Carole:

    Please answer:

    • version of Windows,
    • 32/64bit?,
    • version of FMP,
    • version of MBS.

    There is a brand new release of soSIMPLE (3.83) that includes an updated version of MBS (8.2).

    If you’re using your own copy of MBS please note the following:

    • If you are using FileMaker 16, you need MBS 7.2,
    • If you’re using FileMaker 17 on Windows, you need MBS 8.2
    • soSIMPLE will use whatever version you have installed if it meets these requirements. If not, we will install the MBS 8.2 (as of this writing).
    • If you have a valid registration, run your registration command before opening the soSIMPLE Settings file, or running the soSIMPLE startup & registration script from your solution.
    • If you are a developer, and you’re copying scripts or layouts to your solution from the soSIMPLE Settings file, we will install MBS as necessary.
    • If you are an end user, you only need MBS if you want to refresh events individually on the calendar (instead of refreshing all events together). To load & register MBS as an end user, run the script “soSIMPLE Registration & MBS Plugin Loader” from your solution (called from the “Calendar Utility” script, which is pasted into your solution). Use the parameter “noplugin” if you don’t want to load the plugin. If you don’t run this script at all, we won’t attempt to load or register MBS for your end users.

     

  • #75083

    Carole Chaski

    Hi Ken,

    My server runs Windows Server 2012 and FMS 16; I use FMPA 16 on a MacBook Pro laptop. I have not upgraded to FM 17 yet.

    I am using version 3.6 of soSimple, which was the upgrade path available to me from my first purchase in June of 2016.

    I am using version 8.3 of MBS (but I also tested soSimple with version 7.4 and had the same problem). My startup script registers MBS. I don’t think 8.2 would be so different from 8.3 that it would cause this problem (I’ve been using MBS for years and its incremental growth does not usually cause backward compatibility issues).

    I registered my soSimple application after I uploaded it to my server; since I cannot get the scripts into my solution I think I cannot run the registration and startup script as suggested (or I am not understanding you).

    I do not know how to access the Calendar_Utility script since this is not being pasted into my solution, due to the MBS problem.

    I cannot access the Script Workspace in the soSimple calendar db or the Settings db.

    So again, is it possible for me to access and copy the scripts manually as the error messages say to do? And if it is possible as the error messages say, how do I access them?

    Thanks,

    Carole

  • #75084
    admin
    admin
    Keymaster

    I’m sorry you’re having this issue. Can you tell me specifically what error you’re seeing and when? Thanks.

    To copy & paste manually:

    When you purchased soSIMPLE you received a user name and password to access the soSIMPLE Calendar file. The easiest way to use that is to hold the option key down while opening soSIMPLE Calendar file. This will prompt you to login.

    Copy the scripts:

    • You can then open Script Manager and copy the entire soSIMPLE script directory. Paste that into your solution.
    • Edit the “soSIMPLE Calendar Action” script. Make sure the first 3 variable steps in that script are set properly – $data_layout_name, $entry_layout_name and $field_names. The $field_names is a let statement that identifies the fields you’re using in your database.

    Create a web viewer:

    • Assign the url to the web viewer as specified in the settings file.
    • Make sure the web viewer object name is “web_calendar”
  • #75087

    Carole Chaski

    Thanks, Ken. I have logged into the SoSimple Calender  db with my credentials. I am into the db and can get the scripts. But  so you know I do get the error message:

    MBS Filemaker Plugin

    The provided license key has expired. Please contact developer and upgrade. (Plugin Version 8.3.0.06, 1-0-0, “Paradise Partners, Inc”, “Clipboard”, “Developer”, 201802).

    I use MBS for my work so I have version 8.3 installed on my FMS 16 and FMPA 16.  If I integrate SoSimple Calendar into my own solution, will I need to use MBS? I am assuming that any calls to MBS would *simply* 🙂 go through my own installed and properly licensed version., which is registered in my startup script.

    Thank you,

    Carole

  • #75094
    admin
    admin
    Keymaster

    We fixed this behavior in 3.7 or 3.8, so if you register MBS in your own solution before opening soSIMPLE, you shouldn’t see that error. We don’t try to register if you’re already registered. We also include a more current version of MBS.

You must be logged in to reply to this topic.