This topic contains 1 reply, has 2 voices, and was last updated by  admin 6 years, 7 months ago.

  • Author
    Posts
  • #74326

    DWassmer
    Participant

    Hello,

    I have the same problem.

    I have used all tipps , without success.

    By layouts  “Planner” + “Resources”,  there is nothing shown.

    In other example layouts on the website, there ist on the left side an area , where are (for example) the Recources are listed.  This Layout I’m also not able to see.

    (We use standalone-mode)

    • This topic was modified 6 years, 7 months ago by  DWassmer.
    • This topic was modified 6 years, 7 months ago by  admin.
  • #74332

    admin
    Keymaster

    We moved this reply to its own support thread. The original support thread was server-powered and this issue is regarding standalone. The original user can see the resource names, but not the events. From what I understand, you don’t see the view at all.

    Populating the calendar (with events, and with resources) is completely different using standalone mode. When you’re using server-powered mode, all events are queried from the server. When you’re using standalone mode, your scripts export the events and resource list to a data file in your temporary folder. Because the server automates this process with server-powered mode, the standalone method is a little bit less intuitive.

    The trick for standalone resources is in the export script (by default called “Export Events Standalone”).

    There are about 11 lines in this script (see attachment) that are responsible for creating a resource list to be exported, based on the value list that you’re using. The first line defines the name of your value list, the rest of the lines loop through the list of resources to create the code required for soSIMPLE. Assuming you’re using our script, everything there should work with only one modification: make sure the the name of the value list is the same name you’re using:

    Set Variable [ $resource_list ; Value:  ValueListItems ( “”;”<name of your value list here>” ) ]

    Also, make sure that you’ve updated the field data.json to include the correct field name for your resources.

    And (if you’re not seeing events at all) make sure you’ve selected the data.json field in the in export records script step.

    https://www.sosimplesoftware.com/products/calendar-documentation/calendar-builder-reference/deployment-options/use-in-filemaker-profilemaker-go-standalone/

     

     

    Attachments:
    You must be logged in to view attached files.

You must be logged in to reply to this topic.